Help Authoring Tool Comparison

Matthew Ellison

UA Europe?
Why use a HAT at all?

- Automates generation/compilation
- Browser-based output (WebHelp)
- Single-sourcing
- Tri-pane paradigm
- Context-sensitivity
- Indexing
- Other Help-specific features
Other possibilities

- Generic HTML-based authoring tool
- Generic XML-based authoring tool
- Wiki
- Blogging tool
- Notepad
For a HAT

- Targeted towards user assistance
- “Off the shelf” solution
- Integrated one-stop solution for multiple outputs
- Usually requires little or no knowledge of underlying technology
- Some tools offer controls for Dynamic/Embedded Help
Against a HAT

- Non-standard
- May lock you in to proprietary technology
- Potentially less flexible
- Limited capability for content management and re-use
The HAT candidates

- Adobe RoboHelp (also TCS3)
- Author-it
- ComponentOne Doc-To-Help
- EC Software Help & Manual
- MadCap Flare
- WebWorks ePublisher
Features most of the HATs have in common

- TOC / Index / FTS
- MS Help output
- Browser-based Help output (WebHelp)
- Map IDs for context-sensitive Help
- Conditional content
- Variables
- Snippets / embedded topics
- Resource sharing between projects
- DHTML drop-downs
Selection Criteria

- “In a nutshell” description
- Workflow
- UI and usability
- Key strengths
- Key weaknesses
- Own Help
ADOBE ROBOHELP
RoboHelp in a nutshell

- Edit in XHTML using RoboHelp WYSIWYG Editor
- Project settings stored in variety of text files
- For single-sourcing print and Help:
  - Create print document in Word
  - Link Word doc to RoboHelp project
  - Publish through RoboHelp to Help
RoboHelp workflow

Also:
- DITA
- FlashHelp
- JavaHelp
- Eclipse Help
- XML
TCS3

- Same as RoboHelp, except:
  - Can link FrameMaker documents
  - Therefore richer print capability for single-sourcing
TCS3 workflow

Also:
- DITA
- FlashHelp
- JavaHelp
- Eclipse Help
- XML
Whirl the World - Expenses

Expenses incurred while undertaking normal duties can be reclaimed at the end of each calendar month. An advance payment can be made to assist employees meeting significant expenses.

To minimise the amount that employees have to incur before receiving reimbursement, company credit cards will be issued to employees who regularly incur expenses exceeding US$400 per month.
RoboHelp UI and usability

- Retains look-and-feel and key principles from earlier versions
- Many Pods – customizable layout
- Editor formatting UI looks like Word (pre 2007)
- In my opinion: some problems with UI for importing/linking
RoboHelp key strengths

- Indexing and search
- WebHelp output
- AIR Help output
- New Resource Manager
- Integration with Captivate
- Single-sourcing from Word (and from FrameMaker in TCS3)
RoboHelp key weaknesses

- Print documentation output
- Lack of support for importing/linking FrameMaker documents (except within TCS3)
- UI for importing/linking Word and FrameMaker documents
- Very large footprint
RoboHelp’s own Help

Adobe Community Help

Results for: template + RoboHelp
Adobe Forums: RoboHelp Templates
RoboHelp Templates. I am using the TechComm Suite FrameMaker to Robohelp tools. I have create a template in RoboHelp to apply our company ...
forums.adobe.com/thread/223125

Style Mapping in TCS 2 - RoboHelp Way or FrameMaker Way ...
21 Oct 2009 ... He/she simply needs to author his/her styles in FrameMaker and use the particular document as a template in RoboHelp. ...
blogs.adobe.com/techcomm/2009/10/style_mappi...

Adobe Forums: RoboHelp HTML Template
Header borders
I’ve been maintaining a RoboHelp HTML project for a few years and now I’m having to create a new one. I’ve created a template and want to ...
forums.adobe.com/thread/479560

FrameMaker-RoboHelp Integration in TCS revamped!! Myth or Truth ...
28 Jul 2009 ... FM Template Workflow: Users can define their styles for mapping in a FrameMaker template and specify the template in RoboHelp. ...
blogs.adobe.com/techcomm/2009/07/framemak...
Author-it in a nutshell

- All content (for multiple projects) stored in a single Library (database)
- Object-oriented
- Very powerful and flexible re-use across multiple projects
- Permissions based on logon
- Can use SQL Server or free JET / SQL Server Express database
Author-it workflow

Database

- Word
- FM (MIF)
- RH
- HH
- HTML
- HH
- HH
- XML
- HH
- WH
- DITA
- HH
- Word
- PDF

Also:
- Website
- JavaHelp
- Oracle Help
- WinHelp
Author-it UI and usability
Author-it UI and usability

- Ribbon-based
- Multiple windows and components
- Granularity gives flexibility and power, but increased complexity
Author-it key strengths

- Content management
- Structured authoring (without requiring knowledge of XML)
- Role-based permissions
- Object Variants
- Authoring memory (requires Xtend)
- Localization support (requires Localization Manager)
- Project management (requires Project Manager)
- Web-based authoring (requires Author-it Live)
Author-it key weaknesses

- Proprietary storage format
- Uses Word for all print publishing
- No longer aimed specifically at Help authoring
- Potentially over-complex for some needs
Fragment Highlighting

Highlighting is used to visually indicate when fragments, or topics, have been reused, and the level of similarity between fragments. Each of the highlighting colors can be changed in the Author-it Xtd tab in the user options.

There are four types of highlighting used:
- Reused topics: any topics that have been re-used in the library. Reused topics are any topics that have been embedded into a new container topic.
- Reused fragments: any text fragments that have been reused in the library. The text, punctuation, spaces, and styles are an identical match.
- Exact match between fragments: an exact match occurs when two fragments contain identical text. The match is based on the word comparison only, and ignores any differences in white space, capitalization, and punctuation.
- Fuzzy match between fragments: a fuzzy match occurs when the word comparison between two fragments is similar, but not identical. The minimum level of similarity for a match is set in the user options. Based on this setting, only those fragments that are equal to or are above the level of fuzzy match are displayed. Additional levels for fuzzy matching can be defined by the user.

In This Section
- Adding a Custom Highlighting Band
- Changing the Highlighting Color

See Also
- Author-it Xtd
- Barriers to Reusing Content
- Benefits of Using Author-it Xtd
- Reusing Content in the Library
- Author-it Xtd User Options
- Noise Words
- Suggestive Reuse
- Advanced Search
COMPONENTONE DOC-TO-HELP
Doc-To-Help in a nutshell

- Edit in XHTML using Doc-To-Help WYSIWYG Editor
- Alternatively, edit in Word or HTML (using FrontPage or Dreamweaver)
- Add metadata and other special features using D2HTML
- Metadata also stored in an Access database
Doc-To-Help workflow

Also:
- WinHelp

Called NetHelp

MS Help 2
Doc-To-Help UI and usability

Pittsburgh Sites

Pittsburgh has many wonderful scenic and memorable places to visit. Here is a list of just a few of them:

1. **Allagheny Observatory**
   Riverview Park
   Pittsburgh, PA 15214
   412-321-2400

2. **Carnegie Science Center**
   One Allegheny Avenue
   Pittsburgh, PA 15212
   412-237-3400

3. **Duquesne Incline**
   1220 Grandview Avenue
   Pittsburgh, PA 15211
   422-381-1665

4. **Phipps Conservatory and Botanical Gardens**
   One Schenley Park
   Pittsburgh, PA 15213
   412-622-6914

5. **Pittsburgh Zoo & Aquarium**
Doc-To-Help UI and usability

- Improvements in UI from 2007 onwards
- Ribbon-based
- Powerful and flexible Topics tab
- Style sheet concepts can be confusing
- Error messages rather opaque
Doc-To-Help key strengths

- Authoring support for Word, FrontPage and Dreamweaver
- Automatic and customizable “topic relationships”
- New NetHelp search engine
- Support for team authoring without need for source control software
- SharePoint integration
- Support for documenting Class Libraries with Microsoft Sandcastle
Doc-To-Help key weaknesses

- Relatively slow build process
- History of dependence on Word has shaped the product
- Potential synchronization problems between source docs and DTH database
Doc-To-Help’s navigation panes make it possible to quickly work with your documents, table of contents, index, and related topics. Click on the button to expand the pane and open the accompanying window.

See [Navigating Doc-To-Help](#) for information on other navigation methods.

**More:**
- Documents pane
- Contents pane
- Index and Groups pane
- Related Topics pane
EC SOFTWARE HELP & MANUAL
Help & Manual in a nutshell

- Edit in XML using Help & Manual WYSIWYG Editor
- Project settings, styles, and templates all stored in a single project file in XML format
- For single-sourcing print and Help:
  - Generate PDF and Help targets from Help & Manual
Help & Manual workflow

XML

- RTF
- CHM
- RH
- HTML
- Word/PDF
- HH
- WH
- MH 2
- EB

eBook

Also:
- WinHelp
Creating an empty new project

1. Click on the Application Button (the large button in the top left corner of the program) and select New.
2. Select the option Create a new help project and then follow the instructions displayed in the interactive wizard.
3. If you have Help & Manual Professional you can choose between two save formats:
   - Uncompressed XML:
     Saves your project as a collection of XML files. Must be saved in an empty folder. This format is required for multi-user editing. The main project file has the extension .hmxp.
Help & Manual UI and usability

- Ribbon-based
- Simple well-organized UI
- Authoring process driven by TOC structure
- Styles and formatting heavily based on Word paradigm
- Advanced features less exposed
Help & Manual key strengths

- Powerful “skins” for adding advanced features and achieving consistency across projects
- Support for modular Help
- Support for team authoring without need for source control software
- Ability to share resources across projects
- Built-in non-scrolling region support
- Support for documenting Class Libraries with Microsoft Sandcastle
Help & Manual key weaknesses

- List formatting
- No FrameMaker import
- No DITA support
Help & Manual’s own Help

Publishing

Once you have made all your preparations and set your configuration options for the output format you are using compiling is basically just a question of selecting Publish and choosing the output format.

How to publish your project

Publishing ePub eBooks

Publishing selected topics only

For test purposes you can publish only the topics that are currently selected in the Table of Contents pane (TOC). Note that this will result in dead links in topics that contain links to topics which are not included in your output!

1. Select the topics you want to publish in the TOC pane. You can use Ctrl+Click and Shift+Click to select multiple topics out of order and sequences of topics. Selecting chapters automatically selects all the chapters' sub-topics.

2. Select Publish in the Application Menu or the Project tab.

Publish Help Project

Include Options:

Selected Topics
MADCAP FLARE
Flare in a nutshell

- Edit in XHTML using Flare WYSIWYG Editor
- Project settings all stored in XML files
- For single-sourcing print and Help:
  - Generate PDF and Help targets from Flare
Flare workflow

Also:
- DotNetHelp
- FrameMaker
- Word
- AIR

WebHelp Mobile

XHTML

HH

WH

WHM

DITA

HTML

HH

RH

PDF/XPS

Word

FM

DITA

HH
Flare UI and usability

Communicating with students using audio

You can broadcast audio messages or use audio for two-way communication with selected students. This only works if the tutor computer and client computers have audio capabilities (a sound card with a microphone, headphones or speakers attached).

To communicate with students using audio:

1. In the Main window, select one or more client.
Flare UI and usability

- Powerful, fairly complex and slightly quirky workspace
- Many different editors for different file types
- Users benefit from understanding of CSS
- Unusually comprehensive and excellent Help system
Flare key strengths

- WebHelp Mobile output
- Authoring memory (Intellisense)
- Automatic conversion of text to variables (requires MadCap Analyzer)
- Feedback and collaboration (requires Feedback Server or Feedback Service)
- Search filtering
- DotNetHelp format
Flare key weaknesses

- Limited keyboard shortcuts
- Some quirks in PDF output
- Not a true content management system
Deleting Projects

To delete a project completely, you must use Windows Explorer. This operation cannot be done from Flare.

You can also remove projects from displaying in the File>Recent Projects menu and the Start Page in Flare. This does not delete the project, but simply removes it from those shortcut locations.

How to delete a project through Windows

1. In Windows Explorer, browse to the location where you have stored the project (e.g., C:\Documents and settings\Projects\My Project).
2. Delete the folder holding the project files.

How to remove a project from the File>Recent Projects menu and the Start Page in Flare

1. In the Flare project, select File>Recent Projects>Manage Recent Projects. The Recent Projects dialog opens.
2. Highlight the project and click Remove.
3. Click OK.
WEBWORKS EPUBLISHER
WebWorks ePublisher in a nutshell

- Converts content from three possible source formats:
  - FrameMaker
  - Word
  - DITA
- No editor of its own
- Separate products for design, production, and power production
- Large range of output types
WebWorks ePublisher workflow

Also:
- HTML
- JavaHelp
- MS Reader
- Palm Reader
- WinHelp...
WebWorks ePublisher UI and usability
WebWorks ePublisher UI and usability

- Designer product (ePublisher Pro) is complex and requires some technical expertise
- Production product (ePublisher Express) very simple to use
WebWorks ePublisher key strengths

- User-generated content (wiki and Reverb outputs)
- Simple HTML output
- Stationery makes for very straight-forward production
WebWorks ePublisher key weaknesses

- WebHelp output
- No TOC editor
- Documentation / user assistance
Organizing and Managing Styles

In Style Designer, you can organize your styles in a hierarchy and then use inherited properties to reduce design and maintenance time. You can create a hierarchy of similar styles, set the style property values once, and have those values inherited by child styles.

The Prototype style, which is essentially the parent style for all styles, allows you to quickly define properties for all styles. This style allows you to make global changes across all styles that inherit properties from the Prototype style. For example, you may have all styles inherit their font and vertical spacing from the Prototype style.

**Note:** Child styles inherit only property values from a parent style. Child styles do not inherit additional features specified on the Options tab.

By default, all style properties of a parent style are inherited by its child styles. If you change the property values of a parent style, those changes are inherited by the child styles of that parent style. You can override specific properties for a child style to make those not inherited from its parent style. Once the value of a specific property is set at the child level, changes you make to the parent style for that property do not affect the child style.

**To organize styles in Style Designer**

1. Open your Stationery design project.
2. On the View menu, click Style Designer.
3. Click the type of styles you want to organize, such as Paragraph Styles.
4. **If you want to make a style the child of another style,** drag and drop the child style on top of the style you want to make its parent style.
5. Click on the child style and review the properties for that style to make sure it inherits the property values you want from its parent style.

Add New Comment

Optional: Login below.

Type your comment here.
Server-based Help

- HelpServer by 4.ST
- RoboHelp Server
- MadCap Feedback Server
Final comments

- All of the HATs described in this presentation are great tools
- Other HATs are available
- Your best choice depends on your preferred workflow
- Always test drive with real data before purchasing