How long is a topic?
Matthew Ellison

- Consultant and trainer for User Assistance tools and technologies
- Technical Director of annual UA Europe conference
What we’ll cover in this session

- Influence of minimalism on topic length
- What we can learn from wikis and blogs
- Topics as articles
- The issue of narrative flow
- Sizing topics for searching & browsing
- Content re-use and granularity
- Signposting and navigation within topics
Influence of minimalism on topic length

- Some key principles of John Carroll's minimalism:
  - modular
  - task-based
  - get the user up and running as soon as possible
  - make use of prior knowledge
  - guided exploration
Windows 95 Help - based on Minimalist Model?

More ways to customize Windows
There are many new ways to customize Windows.
- Shortcuts on the desktop
- Display properties
- Fonts folder
- User profiles
- Accessibility options for people with disabilities
- System properties

Display properties
You can customize almost any screen element in Windows by using the right mouse button to click the desktop, and then clicking Properties.
In the Display Properties dialog box, you can change the background color or add a bitmap to your desktop; you can change the font used for your menus, title bars, and other elements; and you can choose different screen savers.

To put a shortcut on the desktop
1. Click the item, such as a file, program, folder, printer, or computer, that you want to create a shortcut to.
2. On the File menu, click Create Shortcut.
3. Drag the shortcut icon onto the desktop.

Tips
- You can use the shortcut as a fast way to open the item.
- To change any settings for the shortcut, such as what kind of window it starts in or what key combination is used to access it, use your right mouse button to click the shortcut, and then click Properties.
- To delete a shortcut, drag it to the Recycle Bin. The original item will still exist on the disk where it is stored.
How things have changed!

Customizing Start

You can pick the tiles, colors, and pictures on your Start screen, and organize your apps. If other people use your PC, make sure they all sign in with their own Microsoft account. That way, each person can have their own customized Start screen. To find out more, see Start screen.

To change the background

1. Open Start by swiping in from the right edge of the screen and then tapping Start. (Or, if you're using a mouse, point to the lower-left corner of the screen, move your mouse all the way into the corner, and then click Start.)
2. Swipe in from the right edge of the screen, and then tap Settings. (If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, and then click Settings.)
3. Tap or click Personalize, and then tap or click the background, background color, and accent color you want. The background and accent colors you pick will show up as a theme, as in this recipe and the clock or calendar.

UA Europe?
How things have changed!
What about Information Mapping?

- Should topics have 7 ± 2 chunks?
- How long should those chunks be?
- Is seven really such a magic number when it comes to information design?
What we can learn from blogs and wikis

“The predominance of blogs on the web has set a trend for expected article length and attention span online”

[Tom Johnson]

- Blog posts should be 300+ words for SEO purposes
- 500 words is commonly said to be the ideal length
What we can learn from blogs and wikis

- Wikipedia’s recommendation on article size (in a nutshell):

  Articles should be neither too big nor too small
What do we mean by a topic?

- One idea, one topic?
- A topic supports one task?
- An answer to a question?
- The shortest effective piece of communication?

Let’s agree on:
- a standalone piece of content
My attempt to define a topic

a self-contained cluster of chunks of information, each of which depends on the others for context, on a single theme with an overall narrative flow.
Adobe Captivate Help / Edit audio

Edit audio files
Edit audio timing
Add silence to an audio file
Edit audio using Adobe Audition
Add closed captions to an audio file
Delete audio from a slide
Delete background audio

Edit audio files

You can edit the audio files in your Adobe Captivate project at any time. Using the Edit Audio dialog box, you can listen to an audio file, insert silence, adjust volume, and change numerous other options.

1. Select Audio > Edit and then choose Object, Slide, Slides, Project, or Background depending on your requirement.

   **Note:** The Edit option is enabled if a question slide or a project slide contains an audio file. It is disabled for question pools and random question slides.

2. If you are editing slide audio and the slide contains both narration and system audio, then the Edit tab in the Slides Audio dialog box displays both the audio waveforms (in the patch for subscription and Adobe Software Assurance customers only).
   - To edit only narration audio, click the system audio icon ( ). Only the narration audio waveform is displayed and you can continue editing the audio.
   - To edit only system audio, click the narration icon ( ). Only system audio waveform is displayed and you can continue editing the audio.
   - To perform editing operations simultaneously on both types of audio, click both narration and system audio icons. Both the audio waveforms are displayed. When you select a portion of one audio waveform, the portion of the other audio waveform corresponding to the selected time, also gets selected.

At any point in time, if you want to exclude an audio waveform from editing, click the Remove Selection icon ( ) corresponding to the waveform.
Example 2

Photoshop Help / Levels adjustment

Levels overview
From an expert: Levels command
Adjust tonal range using Levels
Adjust color using Levels
Add contrast to a photo with Levels

Levels overview

You use the Levels adjustment to correct the tonal range and color balance of an image by adjusting intensity levels of image shadows, midtones, and highlights. The Levels histogram is a visual guide for adjusting the image key tones. For more information on how to read a histogram, see About histograms.

You can save Levels settings as a preset, then apply them to other images. See Save adjustment settings and Reapply adjustment settings.
Adding Multimedia Files to Projects

This feature is supported in EPUB and in all online outputs (DotNet Help, Eclipse Help, Microsoft HTML Help, WebHelp, WebHelp 2.0 (HTML5), WebHelp AIR, WebHelp Mobile, and WebHelp Plus.

You can add many types of multimedia files (both video and audio) to your project, which can then be inserted into topics or snippets.

The following steps show you how to add a multimedia file to your project, without inserting it into a topic (or snippet). If you follow the steps for inserting movies or audio (see Inserting Movies and Inserting Audio Files), the multimedia file is added to the project as well.

The traditional location to store a multimedia file in the Content Explorer is in the Resources\Multimedia folder. However, you can store it anywhere in the Content Explorer that you like.

- FILE TYPES
- HOW TO ADD A MULTIMEDIA FILE TO A PROJECT
- NOTE

SEE ALSO

- PDF DOWNLOADS
- VIDEOS
- SUPPORT LINKS
- FOLLOW THE DOC TEAM
The issue of narrative flow

“For whatever minimum amount of content that reader needs in order to get back to their task, they will get to their task faster if there is good narrative flow within that content.”

[Mark Baker]
Topics as articles

- Google, Microsoft, and Adobe now label their Help topics as “Articles”

- The term “Article” implies:
  - Longer
  - More independent
Topics as articles

“If I ... approached technical instruction as a series of articles, which fit together coherently, somewhat like on a blog, I would do a much better job.”

[Tom Johnson]

- Tom favors longer topics
  - “The real focus in help should be on expanding the concepts, and the concepts should be written in a way that fits together coherently.”
Sizing topics for searching & browsing

- Trade-off between:
  - too many search results (short topics)
  - too much scrolling/scanning (long topics)

- Important to consider browsing too:
  - argument for longer topics?
  - breadcrumbs and “related topics” links are vital
More about lists
Change bullet style
Turn your text into a bulleted list
Create an outline

Related Topics
Basic Steps in Improving Photographs
How to Approach Colour, Contrast, and Saturation Adjustments
Common Problems and How to Solve Them
Improving Colours
Improving Saturation
Removing Source Defects
Removing Image Defects and Noise
Correcting Image Distortions
Retouching Photographs
Improving Image Clarity

Adobe also recommends
- Making quick tonal adjustments
- Adjusting image color and tone

Parent topic: Packaging assets for reuse
Related concepts
RAS assets
Related reference
RAS asset icons
Feedback
(C) Copyright IBM Corporation 2004, 2005. All Rights Reserved.

Tips and advice can be found here:
⇒ Tips for Optimizing System Startup

Back to Overview:
⇒ Disabling Startup Programs
Taking longer topics to the extreme...

- Single Page Docs – stop the click insanity
  
  [Brandon Philips]
Content re-use and granularity

- "Narrative isn’t one of the genres meant for any kinds of re-use."
  [Rahel Anne Bailie]

- Shorter topics have more potential for re-use
- Re-use can be at a more granular level than topics
“Technical documentation is something else that’s far more structured than other kinds of writing. There are sections and subsections and tables and lists of tasks, etc. Each of these things brings with it some kinds of content boundaries that encapsulate it, and allow it to stand on its own, and thus be managed somewhere else and then reused.”

[Deane Barker]
So, how long should a topic be?

It depends

As long as it needs to be to answer the reader’s question
Create a bulleted or numbered list

1. Type * (asterisk) or Shift+Ctrl+L to start a bulleted list or 1. to start a numbered list, and then press SPACEBAR or the TAB key.
2. Type some text.
3. Press ENTER to add the next list item.
   Word automatically inserts the next bullet or number.
4. To finish the list, press ENTER twice, or press BACKSPACE to delete the last bullet or number in the list.
   TIP You can use a different bullet or numbering style by clicking the arrow next to Home>Paragraph>Bullets or Home>Paragraph>Numbering and clicking a new style.

If bullets and numbering do not begin automatically
1. Click File>Options>Proofing.
2. Click AutoCorrect Options, and then click the AutoFormat As You Type tab.
3. Under Apply as you type, select the Automatic bulleted lists check box and the Automatic numbered lists check box.

Spread out the items in a list
Increase the space between the lines in all of your lists by clearing a check box.
1. Click Home>Paragraph Dialog Box Launcher.

2. On the Indents and Spacing tab, under Spacing, clear the check box for Don’t add space between paragraphs of the same style.

More about lists
Change bullet style
Turn your text into a bulleted list
Create an outline

Did this article help you?

Yes  No  Not what I was looking for
So, how long should a topic be?

It depends

As long as it needs to be to answer the reader’s question

But:
users must be aware of the full scope of the topic
Signposting and navigation within topics

- Enable users to see full scope of topic

Examples

Build on the basic template above with Bootstrap's many components. See also Customizing Bootstrap for tips on maintaining your own Bootstrap variants.

Using the framework

- Bootstrap starter template
  - Nothing but the basics: compiled CSS and JavaScript along with a container.
- Hello, world!
  - This is a simple example of a Bootstrap website. It includes a basic template and user navigation.
- Buttons
  - Basic Bootstrap buttons for user interaction.
- Thumbnails
  - Bootstrap thumbnails for content preview.
- Grids
  - Multiple examples of grid layouts with all four tiers, nesting, and more.

Download

- What's included
- Basic template
  - Examples
    - Using the framework
    - Navbars in action
    - Custom components
    - Experiments

Community

- Disabling responsiveness
- Migrating from 2.x to 3.0
- Browser and device support
- Third party support
- Accessibility
- License FAQs

Customizing Bootstrap

Translations

Back to top
Signposting and navigation within topics

- Use affordances within a topic to indicate flow between topics

```python
from filebrowser.sites import site as fb_site
urlpatterns += patterns('',
    url(r'^admin/filebrowser/', include(fb_site.urls)),
)
```

This package either uses the standard Django `ImageField`, or the image field from any other supported application. When `sort-thumbnail` is installed, it will be used; when `django-filebrowser-nograpelli-django14` is available it’s used instead.

For more information, see the documentation of `django-any-imagefield`.

**Custom HTML / WYSIWYG fields**

The `text_plugin` and `PluginHTMLField` use `django-wysiwyg` to display a WYSIWYG editor.

It’s possible to switch to any WYSIWYG editor of your choice. The default editor is the YUI editor, because it works out of the box. Other editors, like the `CKEditor`, `Redactor` and `TinyMCE` are supported with some additional configuration.

For more information, see the documentation of `django-wysiwyg`.

© Copyright 2011-2013, Diederik van der Boor.

Sphinx theme provided by Read the Docs
But only if there is genuine flow

Next →
I'm using my phone in Uzbekistan, why can't I download and/or send media files properly?
A topic is as long or as short as it needs to be
A topic consists of pieces of information that depend on each other
300+ words is good for SEO
Shorter topics enable greater re-use
Enable users to see the full topic scope
References

- Minimalism and Documentation (Mary Ann Eiler)
  http://kairos.technorhetoric.net/3.1/reviews/eiler/minimal.html

- The Secrets of Blog Post Length (Susan Gunelius)

- How to Calculate the Ideal Blog Post Length (Kyle Chowning)

- Wikipedia: Article size

- What is a topic? What does standalone mean? (Mark Baker)
References

- Misconceptions about Topic-Based Authoring (Tom Johnson)  

- Do Short Topics Make Information More Findable? (Tom Johnson)  
  http://idratherbewriting.com/2013/05/05/do-short-topics-make-information-more-findable/

- Why Long Topics Are Better for the User (Tom Johnson)  
  http://idratherbewriting.com/2013/05/06/why-long-topics-are-better-for-the-user/

- Single-page Docs: Stop the click insanity (Brandon Philips)  
  http://lanyrd.com/2013/writethedocs/scfpdh/ and  
  http://www.youtube.com/watch?v=rXcdTYuxwys
References

- Content Re-use and Narrative Flow (Rahel Anne Bailie)
  [http://intentionaldesign.ca/2013/01/06/content-re-use-and-narrative-flow/](http://intentionaldesign.ca/2013/01/06/content-re-use-and-narrative-flow/)

- Topic size: Finding the narrative minim (Mark Baker)

- Content Reuse and The Problem of Narrative Flow (Deane Barker)
Samples

- Example 2: http://helpx.adobe.com/photoshop/using/levels-adjustment.html
- Example 3: http://webhelp.madcapsoftware.com/flare9/Content/Multimedia/Adding_Multimedia_Files_to_Projects.htm

- Word Help: Create a bulleted or numbered list http://office.microsoft.com/en-us/word-help/create-a-bulleted-or-numbered-list-HA102840173.aspx
Samples

- Word Help: Use Word mail merge for email

- Twitter Bootstrap documentation (single page with signposting that enables users to see full scope of topic)

- django-fluent-contents’ documentation (multiple pages with Next and Previous buttons)

- WhatsApp FAQs: What is Voice Messaging?
Questions?

matthew@uaeurope.com